UnloadNamespace issues

I encountered a problem with UnloadNamespace in the shiny server. I created a new package, reinstalled all the packages mentioned with dependencies, and restart R, but the problems are still unresolved.
Thank you for your support and guidance.

1 Like

Hi @mt2022 , you need upload igraph. Maybe with remotes delete and re install.

Thanks. @M_AcostaCH . I tried it, but it's not working. The igraph I installed is version 1.3.4. The error showed igraph version 1.3.1.

Maybe you are installing the new version into your user level package library, shiny-server runs as the user shiny so you need to install packages into the system level package library for shiny-server to be able to use it .

To do this you can install packages with sudo from a system terminal, for example:

sudo su - -c "R -e \"install.packages('igraph', repos='http://cran.rstudio.com/')\""

Thanks @andresrcs . The igraph issue is solved now.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.