Unkwon Problem for Using Rstudio

I needed to install a package called "gee". I got an error. It said I should have had Rtool in my R. I tried to install Rtool, but it gave another error. It was related to my R version because it is an old version (R-3.6.2). I tried to download the new version of R (R-4.0.0). Then I tried to install Rtool, it showed the previous error. It said the current version is R-3.6.2. Now, how can I adjust my R to the new version? Second, after adjusting the new R version, do I need to update Rstudio? In other words, is it necessary to update Rstudio?
Thank you very much.

How are you triying to install RTools? If you are using R 4.0.0 you can download the software from here:

Not mandatory but it would be a good idea.

Thanks for the reply.
I told it before. I already downloaded and installed R version R-4.0.0 which is newly released, but my computer still using the old one, not the new one. Why? I do not know. It is the point that I want to know and solve my problem. After solving this step, I will move into the Rtool installation that it is required in Windows OS.

Have you saved the version number in registry?


Even if you haven't, on the Windows version you can change the used R version by holding the Ctrl key while opening RStudio, then you should see this menu and select the desired version.

The first photo was there and it is done, but I did get the second one. Where is the table? Please tell me its address.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.