Unknown SSL protocol error in connection to api.shinyapps.io:443


I am trying to deploy an app to shinyapps.io but unable to establish a connection. I'm using RCurl proxy option. This worked in the past but doesn't seem to be working now. The last version that worked was R 3.5.1 a year ago. I am using rsconnect 0.8.16 and shiny now and have tried multiple R versions.

Below is my log

*   Trying
* Connected to bcp-ab-01.ebmud ( port 3128 (#0)
* Establish HTTP proxy tunnel to api.shinyapps.io:443
* Proxy auth using Basic with user 'kngo'
> CONNECT api.shinyapps.io:443 HTTP/1.1
Host: api.shinyapps.io:443
Proxy-Authorization: Basic a25nbzozYm11ZGtuZzAh
User-Agent: rsconnect/0.8.16
Proxy-Connection: Keep-Alive
Date: Wed, 25 Mar 2020 16:52:29 GMT
X-Auth-Token: FF3B6345DEF5FF21B16387A026C89658
X-Auth-Signature: ZTA2MTAyN2UwYWRkMzQ5NGNlZmM2MDMzZmZiMzc3Yjk5MTVjNzgzMTE3ODRiY2M4OGJmNjM5MTFmMGM1NDhlNg==; version=1
X-Content-Checksum: d41d8cd98f00b204e9800998ecf8427e

< HTTP/1.1 200 Connection established
* Proxy replied OK to CONNECT request
* successfully set certificate verify locations:
*   CAfile: C:/Users/kngo/Documents/R/R-3.6.3/library/RCurl/etc/ca-bundle.crt
  CApath: none
* Unknown SSL protocol error in connection to api.shinyapps.io:443 
* Closing connection 0

I can't understand why the connection gets closed. Am at a complete lost now. Can someone please help?

Thanks a bunch.

  • Kaitlyn

Please make certain the proxy you are using is capable of supporting TLSv1.2, as prior versions were disabled for shinyapps.io last fall.

Hi Josh,

Thank you so much for your reply. Unfortunately this doesn't look like a proxy issue. Our IT team confirm that they support TSv1.2 and that this has been going through. It looks like something might be wrong with the package? I checked all the rsconnect dependencies and so far the packages are the latest version. I also have the latest version of RStudio and R. Not sure what could be the issue.

rsconnect moved away from using RCurl as the default due to it being unmaintained and lacking support for the latest protocols. Can you attempt to switch to the default and configure its proxy settings?

Turns out this is an issue with our firewall and nothing to do with the rsconnect package. Our IT team was able to help resolve this. Thanks again for all your feedback. Really appreciate it!

1 Like