Unable to upload CSV files to RStudio Desktop

For the last few days, I've noticed that the desktop version of RStudio (Mac) no longer gives me an option to upload files (unlike RStudio Cloud, where everything is fine).

I have uninstalled and reinstalled R & RStudio, but am still having this issue. Any idea what's going on/how I can fix this?

Thanks in advance for your help!

If you are using the desktop version you don't need to "upload" anything, RStudio has access to your local files, you just have to look for the file on the "file" tab. Rstudio Cloud has this option because it runs on a remote server, ergo, it doesn't has access to your local files and you need to upload them.


Aha! Thank you so much from someone who is clearly an RStudio newbie!

I just tried this and while I can see the file, I can't get it into RStudio. When I hit "Import Dataset" in the workspace, I get a message that says: "preparing data import requires an updated version of the Rcpp package."

If I hit "yes," it looks like it's installing something, but nothing happens.

I then tried installing it using the "Install" command from the toolbar, and got the below code. I have no idea what this means... can anyone help, please?

> install.packages("Rcpp")

  There is a binary version available but the source version is later:
     binary  source needs_compilation
Rcpp  1.0.4              TRUE

Do you want to install from sources the package which needs compilation? (Yes/no/cancel) Yes
installing the source package ‘Rcpp’

trying URL 'https://cran.rstudio.com/src/contrib/Rcpp_1.0.4.6.tar.gz'
Content type 'application/x-gzip' length 2751467 bytes (2.6 MB)
downloaded 2.6 MB

* installing *source* package ‘Rcpp’ ...
** package ‘Rcpp’ successfully unpacked and MD5 sums checked
** using staged installation
** libs
xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun
ERROR: compilation failed for package ‘Rcpp’
* removing ‘/Library/Frameworks/R.framework/Versions/3.6/Resources/library/Rcpp’
Warning in install.packages :
  installation of package ‘Rcpp’ had non-zero exit status

The downloaded source packages are in

The easiest solution would be to answer "no" to this question, you would get a precompiled binary version that is a little older but much easier to install.
If you need to install the latest version from source, then you need to install xcode in your system (not in R) and the recommended development tools for MacOS systems.

I will try that. Thank you so much.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.