Unable to republish a Bookdown book created in RStudio to bookdown.org using RSConnect after updates.

I am having trouble republishing my book written in RStudio. Published through RSConnect.

It had been about a year since I last tried to republish. During that time my software and some packages had gone out of date. I updated everything, restarted RStudio then built my book in RStudio (bookdown::gitbook). That worked. But when I attempt to publish to my “where-are-genes” web site I get an error message (I will post it if someone needs it).

What I noticed . . .

If I republish to an old web address (where-are-genes-2021) it works fine. This is NOT a good solution for me. I prefer to publish to the original site address (where-are-genes).

The only difference I see in the publishing process (and I think this is significant) is the following:

When I attempt to republish over the desired website

The “Publish to Server” window says the following:

Publish Files From:

The files that are listed within the window are all the .Rmd files among others (including the folder _book mentioned below).

But . . . .

When I republish to to the undesired web site

The “Publish to Server” window says

Publish Files From:

The files that are listed within this window are mostly .html files corresponding to the original .Rmd files in the parent folder.

So, I believe if I could just change the “Publish Files From” path from “…/com~apple~CloudDocs/Where-are-genes” to “…/Where-are-genes/_book” I would be able to update the site I like with my latest content from 2023.

How do I change the path that "Publish Files From" points to?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.