Unable to (re)install rJava on Rstudio (macOS)

I recently (tried) to install rJava to do some spatial modelling on my macOS (version 11.6) using Rstudio (Darwin 20.6.0) and have run into some trouble. I had it installed and then uninstalled it because I needed to change something. However when I went to reinstall it I received the error:

Error: package or namespace load failed for ‘rJava’:
.onLoad failed in loadNamespace() for 'rJava', details:
call: FUN(X[[i]], ...)
error: no such symbol PushToREXP in package rJava

I read that this was due to me uninstalling it and was wondering if there was an easy fix as I couldn't find any online. I am using rJava version 1.0-5.

Please let me know if I can provide any more information.

Not sure if it’d be the same for Mac, but that was a similar message between the 32 and 64 bit versions of R. For windows, when I changed the version that was used in the settings of rstudio and tried to reload it, it went away, so you could try that to see if it fixes. Good luck.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.