Unable to open RStudio in MAC

I opened my Rstudio after few weeks, and now its not even starting. I am using version 1.1.456.
When I open R studio the app remain in this state

Then this popup comes ,

and if I press waiting it will remain like the above for ever. If I press terminate then I get this error

I tried resetting https://support.rstudio.com/hc/en-us/articles/200534577-Resetting-RStudio-Desktop-s-State , but dint helped. I even uninstalled , but still the same. I even tried installing the preview version RStudio v1.2.1030-1 Preview, this time the app loads up. But again this is how it comes, I cant do anything as for some reason something already is running (which I have no idea what it is). If I press terminate then it waits for ever.

Someone please help me, as I cant do anything which I used to do in rstudio IDE. I cant put more image as I am a new user :frowning:

This is how the new R looks when I open (the preview version)

The popupo I mentioned in the post

How did you install R itself? I would suggest re-installing a fresh R from CRAN to see if RStudio can talk to that https://cran.r-project.org

I installed it from the pkg. I even reinstalled it now, but it din't help :frowning:

1 Like

In a bash shell (available by /Applications/Utils/Terminal.app on the Mac) what do you see if you type "which R" (then enter)? On my mac it is "/usr/local/bin/R". I am just wondering if there is some sort of other install (such as R in Anaconda) that is getting in the way.

Even I am getting /usr/local/bin/R

So I want to give an update on the latest preview version of R.
It came up (from the screen shot state) after waiting for 20 min.. But I really don't get why it's waiting for ever.

So looks like it was loading an old .RData .. I deleted it and now it looks fine.

Thank you @JohnMount for jumping in.

1 Like

Oh- I should have thought of that. Definitely consider trying to switch your work flow to not auto-loading and auto-saving the workspace (as it can hurt). There are some preferences in RStudio that can turn that off.


Thank you. Sure will look at it :slight_smile:

1 Like