unable to load tidyverse in rstudio cloud

#> Error: package or namespace load failed for 'tidyverse' in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
#>  namespace 'rlang' 0.4.5 is already loaded, but >= is required

Created on 2020-04-26 by the reprex package (v0.3.0)

unable to load tidyverse in rstudio cloud. I am getting the above error, i tried to remove rlang and tidyverse and then again reinstalled it but the problem persists. Could you please help? many thanks.

I was able to update the rlang with the following command & it worked.

devtools::install_github("r-lib/rlang", build_vignettes = TRUE)

#> R version 3.6.0 (2019-04-26)
#> Platform: x86_64-pc-linux-gnu (64-bit)
#> Running under: Ubuntu 16.04.6 LTS
#> Matrix products: default
#> BLAS:   /usr/lib/atlas-base/atlas/libblas.so.3.0
#> LAPACK: /usr/lib/atlas-base/atlas/liblapack.so.3.0
#> locale:
#>  [1] LC_CTYPE=C.UTF-8       LC_NUMERIC=C           LC_TIME=C.UTF-8       
#>  [7] LC_PAPER=C.UTF-8       LC_NAME=C              LC_ADDRESS=C          
#> attached base packages:
#> [1] stats     graphics  grDevices utils     datasets  methods   base     
#> loaded via a namespace (and not attached):
#>  [1] compiler_3.6.0   magrittr_1.5     tools_3.6.0      htmltools_0.4.0 
#>  [5] yaml_2.2.1       Rcpp_1.0.4       stringi_1.4.6    rmarkdown_1.13  
#>  [9] highr_0.8        knitr_1.23       stringr_1.4.0    xfun_0.7        
#> [13] digest_0.6.25    rlang_0.4.5.9000 evaluate_0.14

Created on 2020-04-27 by the reprex package (v0.3.0)

However when i loading the rlang using the library(rlang) I am getting the error.

Error in value[3L] :
Package ‘rlang’ version 0.4.5 cannot be unloaded:
Error in unloadNamespace(package) : namespace ‘rlang’ is imported by ‘vctrs’, ‘testthat’, ‘reprex’, ‘lifecycle’, ‘ellipsis’, ‘usethis’, ‘ggplot2’, ‘tibble’, ‘tidyquant’, ‘htmltools’, ‘pillar’, ‘pkgload’ so cannot be unloaded
and the above error with loading the tidyverse continues.

Restart your R session, and try again. If the problem persists, relaunch your project but download a copy of your files first, just in case.


thank you very much !! it worked after restarting with updated rlang version:).

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.