unable to load package "pattern plot" after installing.

Error Information: Error: package or namespace load failed for ‘patternplot’ in dyn.load(file, DLLpath = DLLpath, ...):

unable to load shared object '/Library/Frameworks/R.framework/Versions/4.0/Resources/library/png/libs/png.so':
dlopen(/Library/Frameworks/R.framework/Versions/4.0/Resources/library/png/libs/png.so, 6): Symbol not found: _inflateValidate
Referenced from: /Library/Frameworks/R.framework/Versions/4.0/Resources/library/png/libs/png.so (which was built for Mac OS X 10.13)
Expected in: /usr/lib/libz.1.dylib
in /Library/Frameworks/R.framework/Versions/4.0/Resources/library/png/libs/png.so
Description of issue - After updating R to the latest version (4.0.0) I have been unable to install packages from source only by binary. I have ggplot and dplyr installed but from binary and I think that is why I get an error when trying to upload pattern plot. Please help!!!

Steps taken so far - I have tried uninstalling Rstudio and re-installing but get the same error

System Information:

  • RStudio Edition: (Desktop or Server)
  • RStudio Version: 1.3.959
  • OS Version: 10.12.6
  • R Version: 4.0.0


  • RStudio diagnostics report:
  • Your sessionInfo():
  • RStudio crash report:
  • RStudio application log files:

From Troubleshooting Guide: Using RStudio

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.