unable to install rhdfs package

Hi Team

Been trying to install 'RHDFS' package in R studio desktop , R cmd , and CDSW -R terminal.

Tried installing in all these environments.But still i m seeing error message saying it is not available for current R version.Tried on 3.4.4 version and 3.5.2 versions as well.

Can you please tell me how to install rhdfs package.


That package isn't on CRAN, it's on github:

Have tried using github function ..
devtools::install_github("RevolutionAnalytics/rhdfs", subdir = "pkg")

but unable to install it. got below error.

devtools::install_github("RevolutionAnalytics/rhdfs", subdir = "pkg")
Downloading GitHub repo RevolutionAnalytics/rhdfs@master
:heavy_check_mark: checking for file ‘/tmp/RtmpW7WUX5/remotes1cc6621f212/RevolutionAnalytics-rhdfs-835d4e5/pkg/DESCRIPTION’
─ preparing ‘rhdfs’:
:heavy_check_mark: checking DESCRIPTION meta-information
─ checking for LF line-endings in source and make files
─ checking for empty or unneeded directories
─ building ‘rhdfs_1.0.8.tar.gz’

Installing package into ‘/home/cdsw/R’
(as ‘lib’ is unspecified)

  • installing source package ‘rhdfs’ ...
    ** R
    ** inst
    ** preparing package for lazy loading
    ** help
    *** installing help indices
    ** building package indices
    ** testing if installed package can be loaded
    Error: package or namespace load failed for ‘rhdfs’:
    .onLoad failed in loadNamespace() for 'rhdfs', details:
    call: fun(libname, pkgname)
    error: Environment variable HADOOP_CMD must be set before loading package rhdfs
    Error: loading failed
    Execution halted
    ERROR: loading failed
  • removing ‘/home/cdsw/R/rhdfs’
    Error in i.p(...) :
    (converted from warning) installation of package ‘/tmp/RtmpW7WUX5/file1cc65323cf4/rhdfs_1.0.8.tar.gz’ had non-zero exit status

This is where it's going wrong. You should read the documentation in the link, but the package hasn't been touched since 2013 so might not be functional anymore.

1 Like

Ohh if it is not functional , do we have to another package with the similar functionality?

I don't know whether it still works or not. You should check the documentation and installation instructions before giving up on it.

There are more details here:

This provides a more general guide to connect with databases, including Hive and Impala on Hadoop platforms:

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.