Unable to install Rdpack

Hi, I want to install PLM package in RStudio. But this package is dependent on Rdpack, which I am not able install at all. I could not find any solution online as well. Please note that I tried re-installing RStudio, R, and all the available packages. Still, I am not able to install Rdpack. As Rdpack is creaing issues, I am not able to install 'plm' package due to dependency. Can somone help?
Command: install.packages('Rdpack')

> install.packages('Rdpack')
Installing package into ‘C:/Users/Jithesh/Documents/R/win-library/3.5’
(as ‘lib’ is unspecified)

  There is a binary version available but the source version is later:
       binary source needs_compilation
Rdpack 0.11-1  1.0.0             FALSE

installing the source package ‘Rdpack’

trying URL 'https://cran.rstudio.com/src/contrib/Rdpack_1.0.0.tar.gz'
Content type 'application/x-gzip' length 659719 bytes (644 KB)
downloaded 644 KB

* installing *source* package 'Rdpack' ...
** package 'Rdpack' successfully unpacked and MD5 sums checked
** R
** inst
** byte-compile and prepare package for lazy loading
** help
*** installing help indices
  converting help for package 'Rdpack'
    finding HTML links ... done
    RStudio_reprompt                        html  
    Rd_combo                                html  
    Rdapply                                 html  
    Rdo2Rdf                                 html  
    Rdo_append_argument                     html  
    Rdo_collect_metadata                    html  
    Rdo_empty_sections                      html  
    Rdo_fetch                               html  
    Rdo_flatinsert                          html  
    Rdo_get_argument_names                  html  
    Rdo_get_insert_pos                      html  
    Rdo_get_item_labels                     html  
    Rdo_insert                              html  
    Rdo_insert_element                      html  
    Rdo_is_newline                          html  
    Rdo_locate                              html  
    Rdo_locate_leaves                       html  
    Rdo_macro                               html  
    Rdo_modify                              html  
    Rdo_modify_simple                       html  
    Rdo_piecetag                            html  
    Rdo_remove_srcref                       html  
    Rdo_reparse                             html  
    Rdo_sections                            html  
    Rdo_set_section                         html  
    Rdo_show                                html  
    Rdo_tag                                 html  
    Rdo_tags                                html  
    Rdo_which                               html  
    Rdpack-package                          html  
Error: argument is of length zero
* removing 'C:/Users/Jithesh/Documents/R/win-library/3.5/Rdpack'
Warning in install.packages :
  installation of package ‘Rdpack’ had non-zero exit status

The downloaded source packages are in

Hello all, I solved the issue. This issue will happen if RStudio is not installed in default location (i.e., C drive), which is a BIG bug in RStudio. Hope they will resolve the issue.
I had to uninstall, RStudio, R, and R-tools, and then, re-install everything on the default C location.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.