Unable to install "fps" package in R studio on my Mac

I tried to install "suffpcr" wish depending on the package "fps" , I guess this last package seems to work just with mac os 10.9. did any one of you succeed to install this package in recent versions of macOS ?

Looks like it might not be a thoroughly tested package, as both packages are only on Github. What happens if you try installing the required version of {fps} with:


Thank you ; I tried this but it gives me this error :
……...clang: error: no such file or directory: '/Library/Frameworks/R.framework/Resources/lib/libc++abi.1.dylib'

make: *** [fps.so] Error 1

ERROR: compilation failed for package ‘fps’

  • removing ‘/Library/Frameworks/R.framework/Versions/4.2/Resources/library/fps’

Warning message:

In i.p(...) :

installation of package ‘/var/folders/td/b970ytzn54g6zhnnfchmfzr40000gn/T//RtmpamyvM4/file2ee6e1dd045/fps_0.1.tar.gz’ had non-zero exit status

Have you installed the Command Line Tools on your mac?

macOS 10.9 is a pretty old version, so you'll have a lot of trouble there with R packages. I assume you also need to use an older version of R, which does not help, either.

For older versions of R, you also need custom compilers. These used to be distributed from https://mac.r-project.org/ but I am not sure if they are still there.

Yep, looks like it won't be easy. I would really ask how much time you're ready to spend to try and get that package running.

On the bright side, you can notice that it has Continuous Integration set as a Github action, so when there was a change last year, this package was rebuilt successfully on an Ubuntu distribution using recent versions of packages. So if all else fails, maybe you could install in a Docker container with an Ubuntu distribution? I'm unfortunately not familiar enough with Github actions to know what was done under the hood to get the package to install.

Good luck!

Thank you all for your answers, (I just saw them now since I was on vacation ) well I tried all that you suggested for me but unfortunately still have a problem even installing all the command line tools for R . It seems that my version of mac is ancient as you mentioned my machine is from 2012 so I should take other one or try to use ubuntu if it works on the mac I well see thanks anyways again

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.