Unable to install certain R packages

Hi everyone,

I have a problem downloading certain R packages on my work computer. Works fine for some packages, ex. ggplot2, but when I'm trying to download dplyr it stops at the following message in the console (see attached code). Any tips that would help is much appreciated.

> install.packages("dplyr")
WARNING: Rtools is required to build R packages but is not currently installed. Please download and install the appropriate version of Rtools before proceeding:

Installing package into β€˜\\storage-al.slu.se/home$/axik0001/My Documents/R/win-library/3.6’
(as β€˜lib’ is unspecified)
also installing the dependencies β€˜BH’, β€˜plogr’

trying URL 'https://cran.rstudio.com/bin/windows/contrib/3.6/BH_1.69.0-1.zip'
Content type 'application/zip' length 19008275 bytes (18.1 MB)
downloaded 18.1 MB

trying URL 'https://cran.rstudio.com/bin/windows/contrib/3.6/plogr_0.2.0.zip'
Content type 'application/zip' length 18868 bytes (18 KB)
downloaded 18 KB

trying URL 'https://cran.rstudio.com/bin/windows/contrib/3.6/dplyr_0.8.3.zip'
Content type 'application/zip' length 3266314 bytes (3.1 MB)
downloaded 3.1 MB



Besides missing Rtools (so you can't compile libraries from source) you are not showing any error messages, maybe it's just taking longer than you expected.

1 Like

For some guidance on installing Rtools see the link below

1 Like

Thanks, got Rtools now and don't get that error message. However, still don't work. Yesterday I let it sit for a few hours and it wouldn't download.

Try unchecking this option, do you get any different outcome?

1 Like

I've tried this and it still gets stuck downloading.

It seems you are installing to a network drive, this brings some issues very often, try installing to a local folder instead.

Thanks a bunch! I managed to create a non-network drive folder and tell R to download packages in this folder. Solved the issue.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.