Unable to establisch connection with R session

I have a problem. I have Windows 10 on Ryzen 5 machine with AMD radeon graphics, R 4.0.3 and Rstudio 1.3.1093. When I run a script some string say "Unable to establisch connection with R session" on console and when I try to open some voice of the main menu as "tools" for example the same message appears in a window on the display with a red X.

There are some open topics, with no solution. I downloaded Rstudio 1.1.463 as suggested by some admin but I think it's a really old version. I also tried:

  1. Try Reinstalling R Studio.
  2. Updating the R packages.
  3. Deactivating your anti-virus software in your machine.
  4. Try reseting RStudio’s state.
  5. Try rendering engine to the software.
  6. Check that you don’t have any .Rdata file in your default working directory.
  7. Do you have the data.table package installed, or are you using it in your project? If so, you might want to try updating it with e.g. install.packages("data.table") .
  8. Installing the preview version, 1.2.792 of R Studio and the issue has gone away.
  9. Resolving unable to establish connection issue by following the below steps.

Anyway someone told it could be OneDrive sync, but I don't know what to do.
Thank you very much for your help

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.