Unable to deploy due to repository configuration issue

I am trying to deploy my webapp to shinyapps.io and I keep getting this:
Error: Unhandled Exception: Child Task 616823365 failed: Error parsing manifest: Unable to determine package source for Bioconductor package flowClust: Repository must be specified
Execution halted

I browse in the same kind of issue in this community and it seems that the reply is quite old since it refers to the BiocInstaller::biocLite old setting

Currently I put on top on my server.R file:
options(repos = c("BioCsoft" = https://bioconductor.org/packages/3.8/bioc"))
but it does not work
could you help?

I think you need to run those lines before deploying in your R sessions if not set already.
rsconnect uses your R sessions configuration to determine the source of your package.

Hope it could help.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.