ubuntu rstudio server upgrade... service not found

I had a 1.1 rstudio server running on my ubuntu 16 server and wanted to upgrade it to 1.2 preview. I didn't explicitly stop the 1.1 process but just ran gdebi on the new installer. I didn't get any errors, but when I visited the web interface, version 1.1 was still active. So I got reckless and started typing in anything I could read about broken package cleanup.

I just re-ran the gdebi installer and didn't get any error messages, but it doesn't look like the service is running or even installed. I have installed rJava, as root, since the error about that at 12:44:24

$ date
Wed Apr  3 13:43:07 UTC 2019

$ sudo service rstudio-server status
● rstudio-server.service
   Loaded: not-found (Reason: No such file or directory)
   Active: inactive (dead)

Apr 03 12:44:24 ip-172-31-90-126 systemd[1]: Stopping RStudio Server...
Apr 03 12:44:24 ip-172-31-90-126 systemd[1]: Stopped RStudio Server.
Apr 03 12:44:24 ip-172-31-90-126 rsession-rstudio[1524]: ERROR r error 4 (R code execution error) [errormsg=Error in .requirePackage(package) : |||  unable to find required package ‘rJava’|||]; OCCURRED AT: rstudio::core::Error rstudio::
Apr 03 12:44:24 ip-172-31-90-126 rsession-trustedcolleague[1777]: ERROR r error 4 (R code execution error) [errormsg=]; OCCURRED AT: rstudio::core::Error rstudio::r::exec::executeSafely(rstudio_boost::function<void()>) /home/ubuntu/rstud
Apr 03 12:44:43 ip-172-31-90-126 systemd[1]: Stopped RStudio Server.

$ R

R version 3.5.3 (2019-03-11) -- "Great Truth"

> library("rJava")

Ugh. I had tried to "upgrade" from the rstudio-server-1.1.463-amd64.deb server to the rstudio-1.2.1335-amd64.deb desktop application. I have the 1.2 server running now.

1 Like

If your question's been answered (even if by you), would you mind choosing a solution? (See FAQ below for how).

Having questions checked as resolved makes it a bit easier to navigate the site visually and see which threads still need help.


Of course. I was just waiting for my account to be taken out of "temporary hold" status.

1 Like

Awesome — thanks! The "solved" UI is kind of non-obvious.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.