Ubuntu 22.04 Rstudio (2022.12.0-353) do not work.

Installing the RStudio (2022.12.0-353) over (2022.07.2-576) update it does not launch correctly.

It doesn't allow me to launch it from the Dock, and if I launch it from the command line it gives me the following error:

user@host:~$ rstudio
libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)
[1308034:1218/080220.736716:ERROR:gpu_init.cc(481)] Passthrough is not supported, GL is desktop, ANGLE is

I don't know how to solve it.

I would appreciate your help.

Looks like something involving the graphics driver and/or hardware. I have these versions running on Pop!_OS, which is Ubuntu 22.04 based, tuned for System 76 hardware, which has an NVDIA card.

Look over the link and see if any of this looks like your setup and try installing an apt that was not installed prior to 22.04. I'll get the release notes for 353 and the github issues.

Didn't see anything in either the release notes or github issues that appears related. This leads me to suspect that

is indicating the your install is lacking a needed graphics driver. You could try from a terminal

sudo apt-get update
sudo apt upgrade
sudo apt autoremove

and if that doesn't work (and you are comfortable with sysadm stuff) installing the libva libraries described in this recent update.

@liturbe Does disabling GPU and switching to software rendering help? We have a support article on changing the rendering engine. About halfway down there are instructions for running with GPU disabled.

@technocrat Thank you for your assistance!

1 Like

Thanks for the help.

I've tried changing the settings but it still doesn't work.

I still can't launch the app from the Dock and it keeps getting the error.

here the error


On the other hand, if I launch the version (2022.07.2-576) it launches correctly and this is the configuration I have.

Try setting the OS integration options in 353 the same way as 576?

Its not posible, there is not the option Enable X11.

I try with the others and nothing.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.