Tweaking syntax highlights for certain knitr engines on RStudio IDE

For Rmd, variety of knitr engines are available in addition to r

For example, asis returns text asis.

However, when editing Rmd files on RStudio IDE, asis chunks are highlighted as if they contain R scripts.


Is there any way to turn off syntax highlight for asis engine?

I'm also curious if there is any way to add highlighting languages.

This seems like a bug to me -- would you mind filing this as a bug report at


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.