tsibble package


I am not able to use library tsibble. This is my first time trying to tackle time series. After installing the tsibble package, when I run the library, I get the following error:

Error: package or namespace load failed for ‘tsibble’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]): namespace ‘rlang’ 0.4.5 is already loaded, but >= 0.4.6 is required

It seems like I need rlang >= 0.4.6 How do I achieve that? Please help!


typically you would use install.packages function which will try to get you the latest available. like


other alternatives are to use the renv package for example

Yes, I tried that too. Now all my older packages have stopped working after starting tsibble. Updating packages also doesn't work. I might have to uninstall my RStudio and R completely and start over fresh.

Uninstalling and reinstalling R and RStudio is working with tsibble and few other older packages I tested work fine as well!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.