Trouble with the RStudio Connect QuickStart?

We just announced the availability of the RStudio QuickStart . You can download it here:

Having Trouble?

Check out other discussions in the QuickStart tag for more focused help, start your own discussion, or feel free to add to the discussion here in this thread!

Some of the most common problems we have seen, along with their fixes, are on our FAQ page:

I visited the quickstart portal but never found any download link for the appliance .ova file. Did I miss something?

1 Like

Interesting! Thanks for sharing!

Do you have an ad blocker installed? It could very well be that this form at the top of the page got blocked, perhaps?

Looks like Firefox does indeed block that form based on its "standard" setting in content blocking. However chromium shows the form without a problem, even with an adblocker like AdBlockPlus running. Chalk that one up as an oddity. Thanks for the recommendation!

Wow! Good to know! I'll pass that along to our website team as a good oddity to know about :slight_smile: Glad you got it resolved!

Hey guys,

Using RStudio Connect QuickStart to provide an real demo of RStudio's pro tool offerings seems like a great idea. However, I encountered a "...does not appear to be a valid server" error (see attached screenshot), in my attempt to deploy a dummy shiny app template from the RStudio IDE also bundled in the QuickStart virtual machine to Connect. Shouldn't everything just work right out of the (virtual) box for this demo? If not, why not?

Also, the RStudio Package Manager URL in QuickStart (http://localhost:5000/packages/cran/latest) is yielding "cannot open URL" errors. Any suggestions?

Can you provide concise steps on how to smoothly install packages from Package Manager and then publish to Connect, all from within IDE Server in QuickStart?


-- Regis --

Per the "Publishing Content" section of the Quickstart Product Tour, you need to configure your RStudio Connect URL to be http://localhost:5000/rsconnect. If you're still seeing errors after that point, let us know :grinning:

Thanks. I am still seeing errors with that URL.

Weird! Do you mind posting a screen shot of the error? (the http:// part is unfortunately very important, otherwise the IDE tries to connect with HTTPS and fails). Have you verified that Connect is up and running at http://localhost:5000/rsconnect/? You can also check in the RStudio Server Pro terminal at http://localhost:5000/rstudio/ with:

sudo systemctl status rstudio-connect

You might want to do the same for package manager:

sudo systemctl status rstudio-pm

I worry that your trial may have not started appropriately, so the services may be dead. :grimacing: In the ideal world, yes, things should all just work out of the (virtual) box :joy: Sorry for the trouble!

Thanks, Cole.

Here's the screenshot and the RPM (RStudio Package Manager) solution for the RPM-to-IDE installation issue. The IDE-to-Connect publishing issue is still unsolved, though, and the screenshot attached in my follow-up post (newbies are limited to 1 image per post) shows that the services appear to be running. The problem with using the QuickStart RPM on localhost was that since the "use secure download method for HTTP" box was not unchecked by default, packages could only be installed via https. Since the QuickStart RPM uses http, I unchecked the box in Tools -> Global Options -> Packages. Unless I am misunderstanding, it might be a good idea to uncheck the box by default in the QuickStart VirtualBox image, so that RPM-to-IDE installation works entirely within QuickStart, right out of the box. (And maybe even use the RPM URL in the primary or secondary package repository box, to really show how RPM can be used?)

RPM-to-IDE installation issue and solution result:

1 Like

QuickStart tool configurations and statuses:

Ok this is good! I'm glad to hear that the services are up! And sorry about the HTTPS troubles on package installation! We will definitely make a note to fix up that configuration and (as you said) have the Package Manager URL preconfigured for package installation. This first pass was admittedly more focused on Connect than on the other products, and I think that shows in the lack of ease here on package installs. Sorry for the trouble and thanks for your patience there!

Mad props on getting all of that information in a single screen-grab! That's really impressive. I don't think I saw the error for the Connect publishing bit, though? Did I miss it? That's the area you are still stuck right? Do you mind copying the error that you are seeing when publishing to Connect?

Glad I could help with the QuickStart VM configs for installations.

The screenshot for the Connect publishing error is in my original post from 3 days ago. Is it showing up? Publishing to QuickStart Connect from QuickStart IDE can't happen because QuickStart IDE can't get through the QuickStart Connect server validation step.

Right. You should change to publish at:

http://localhost:5000/rsconnect instead of localhost:5000

If you set the following in your R session, you should be able to see a bit more information about the request that is failing too:

options(rsconnect.http.verbose = TRUE)
options(rsconnect.http.trace.json = TRUE)

It should work just fine from within the QuickStart IDE, so long as you are using http://localhost:5000/rsconnect/, like @Blair09M mentioned above.

If it's still failing, can you send an updated copy of the error message, as well as the more verbose output printed to your R session when the options above are enabled?

@rpodcast We have updated the site in an attempt to deal with the disappearing form issue. Is the issue remedied for you?

Is it possible to try it out on Linux-based systems?

Of course!! That’s a great question. You will just need to install VirtualBox. Some of the user interface items on getting things started may differ from our docs / examples, but the function is exactly the same.

I don’t have any articles handy, but a search for installing VirtualBox on your OS will probably be fruitful. Be sure to generate a new MAC address when importing the image to be sure you get a full trial! (And please let us know if you have trouble!).

I visited the link in Firefox and the form shows up perfectly this time! :+1:

1 Like

Thanks @cole and @Blair09M. I thought I had it configured to use http://localhost:5000/rsconnect/, as you suggested, but apparently not. When I updated the URL accordingly, it worked.

In conclusion, the steps below are necessary to connect RStudio IDE Server to RStudio Package Manager (PM) and to RStudio Connect.

How to connect IDE Server to Package Manager and to Connect in QuickStart:

  1. Add PM to IDE:
    In the menu at the top of IDE, navigate to Tools -> Global Options -> Packages -> Connect -> RStudio Connect, and replace Primary
    CRAN repository with the QuickStart PM URL http://localhost:5000/packages/cran/latest/. Then, allow IDE to connect to the non-HTTPS URL that PM is hosted on within QuickStart by unchecking the "Use secure download method for HTTP" box.
  2. Add Connect to IDE:
    In the menu at the top of IDE, navigate to Tools -> Global Options -> Publishing, paste the QuickStart Connect URL http://localhost:5000/rsconnect into the box, and click Next. Then, follow the steps as that it takes you through.

Given that the purpose of QuickStart is to evaluate how these three tools work together, though, couldn't these steps be shown right on the Getting Started page, rather than at the bottom of the Product Tour page? Reviewing the Product Tour page might not seem necessary to developers who just want to get started with QuickStart because they have already been hearing about the trio. Also, couldn't the QuickStart VirtualBox image itself also just ship with these configurations already made as defaults, so that developers can get up and running even faster?

-- Regis --

1 Like

Glad to hear you got it fixed!! And yes, you are spot on with your integrations - thanks for sharing that for the community! You are also spot on with the weakness of us not (a) documenting integration at the forefront or (b) having the products integrated out of the (virtual :wink: ) box. It is definitely something we plan to address in the future - our first pass was admittedly focused on RStudio Connect, while including the other products. We really want the QuickStart to be exactly what you describe - a place where all of the products can be seen and used together. However, as a v1 of sorts, we tried to narrow the scope a bit since Connect is the product that is hardest for users to see / understand, but it solves many of the problems that we see companies having in their data science workflows.

It has really encouraged us to see the community (1) downloading the QuickStart, (2) using it, and (3) giving super useful feedback!! So thanks for being a part of that! :smiley: It definitely helps us justify the extra polish to tie off some of these loose ends that we left open. Please continue to share your feedback - we love hearing about the strengths and the weaknesses of the QuickStart!