Trouble with Pandoc and pkgdown on OSX (likely a brew issue)

One of my OSX laptops has gotten into this state where it can, through RStuidio, build vignettes- but fails on pkgdown::build_site() with a message of the form:

Building news ----------------------------------------------------------------------------------------------
--smart/-S has been removed.  Use +smart or -smart extension instead.
For example: pandoc -f markdown+smart -t markdown-smart.
Try pandoc --help for more information.
Error: pandoc document conversion failed with error 2

My suspicion is that the Pandoc brew put on is newer than what pkgdown expects. Is there any way to force pkgdown to use the version of Pandoc that comes with RStudio and not also include possibly newer versions from the search path?

Everything is up to date and pandoc --version on /usr/local/bin/pandoc returns 2.1.3.

This looks a bit like , so I am going to try updating pkgdown with devtools (I mistakenly thought it was available through CRAN). The following solved it on one machine.


However, that command on another OSX machine broke pkgdown with:

Error: Can't find template for content-license.

However, re-starting and re-building seemed to clear that error.

I guess I would delete this post if I knew how, as I have seem to gotten back into working states on two machines.

No actual problem- updating and re-starting solved.