Trouble transferring and installing packages to secure desktop

Hi everyone, I recently gained access to a secure virtual desktop to access data that I'll be working with. The desktop has the latest versions of R and RStudio, but I have to bring my packages into the desktop by uploading them from my PC to Box and downloading them from Box on the desktop. Unfortunately, the desktop can only access Box, so I cannot install packages using URLs (the typical "install.packages()" way). I've done this for other software, but I haven't been able to get this to work yet for R. Here's what I've tried:

  • First, I put a couple of sample packages on Box and downloaded them as .zip files on the desktop. In RStudio I clicked "tools" -> "install packages" and followed the instructions. This gave an error that the packages were from an old version of R.

  • So I went back to my PC, updated R and RStudio, and updated all packages. I then uploaded the new packages to Box and tried installing them again on the desktop with the same method. This time, it successfully installed the package. However, when I go to reference the package it gives an error saying that the package was installed before 4.0.0 and that I need to reinstall it. Below is a screenshot of the console.


Does anyone have any ideas for how to proceed? I haven't been able to find anyone with similar a situation. If it matters at all, I have probably ~100 packages that I'm trying to transfer over.

Thanks in advance for any help or advice!

Have you updated your packages with checkBuilt =TRUE option? This is needed after a major R update.

Thank you - I hadn't checked that option, so that may be it. I'll go back and redo the updates.

I just got a few of the packages to work by manually extracting files to the directory R looks at for packages, and then simply referencing them from R (i.e. library(packagename)). I'm not sure why I didn't try this before. However, some packages aren't working, such as tidyr. It may be because of the option you mention or because it has other package dependencies, so I'll go back and see.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.