Trouble installing ComplexHeatmap packages in (RStudio) R version 3.6.3


I am having trouble installing ComplexHeatmap and its dependencies in r. It used to work in my previous lower R versions but when I upgraded the software to what my operating system can take (Mac OS X EL Capitan version 10.11.6) which is R version 3.6.3 I run into issues of not being able to install dependencies like the ones below.

library("ComplexHeatmap", lib.loc="/Library/Frameworks/R.framework/Versions/3.6/Resources/library")
Loading required package: grid
Error: package or namespace load failed for ‘ComplexHeatmap’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
there is no package called ‘rjson’

Upon trying to install "rjson"

Warning in install.packages :
package ‘rjson’ is not available (for R version 3.6.3)

Another package required for ComplexHeatmap is Heatmap. Trying to install it is get the information below.

Warning in install.packages :
package ‘Heatmap’ is not available (for R version 3.6.3)

I have also tried to resolve these issues following the discussion in this forum in vain. May I get help from someone please.


Had the similar issue. Found the solution here.

In brief,

(a) Downloaded the archived version of rjson. (Index of /src/contrib/Archive/rjson )

(b) Installed the package locally

(c) Re-run : install_github("jokergoo/ComplexHeatmap")

Worked for me.

I had the same problem. But I resolve in this way:


I work with the version 3.6.3. and I obtained the heatmaps.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.