Tidyverse suddenly collapses

So my entire suite of tidyverse packages has decided it will no longer load. I did not do anything or change anything and suddenly scripts that worked last Wednesday are no longer working today.

Here is just a sample of the errors I am getting, when I try to load ggplot2:

    Error: package or namespace load failed for ‘ggplot2’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
     namespace ‘pillar’ 1.2.2 is being loaded, but >= 1.3.1 is required

So then I tried to install 'pillar' and got this

    installing the source package ‘pillar’
    trying URL 'https://cran.rstudio.com/src/contrib/pillar_1.4.2.tar.gz'
    Content type 'application/x-gzip' length 228815 bytes (223 KB)
    downloaded 223 KB
    'C:\Program' is not recognized as an internal or external command,
    operable program or batch file.
    Warning in install.packages :
      running command '"C:/Program Files/R/R-34~1.1/bin/x64/R" CMD INSTALL -l "C:\Users\60129180\Documents\R\win-library\3.4" C:\Temp\Rtmp8qhyCz/downloaded_packages/pillar_1.4.2.tar.gz' had status 1
    Warning in install.packages :
      installation of package ‘pillar’ had non-zero exit status

This seems to be an error of filepath specification, but it is a very recent one as the install.packages() function has worked fine up to now. I find it so disconcerting when something that used to work suddenly no longer works and I have made no changes.

Is the above message specific to installing pillar, or does that happen with other packages as well?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.