tidyverse stopped working on my windows 10 system!

Hey folks:

Came in this fired up a script that called "library(tidyverse)" and got this:

I've googled for this error, and got nothing.

I'm running latest stable version of windows 10. Just uninstalled and then reinstalled R, RTools and RStudio Desktop. Tried again and got the same error.


The error message is telling you that you are missing the utf8 package, try installing it



Now getting an error in trying to install utf8!

R has problems with cloud synced folders (OneDrive in your case) I recommend you to set your package library in a non synced folder.

You can change the default library folder by setting your R_LIBS_SITE environmental variable in a .Reviron or .Rprofile file. For example:

# In a .Renviron file you can set it by adding a line like this one with the desired location 
R_LIBS_SITE="C:\\Program Files\\R\\R-4.1.2\\library"

For a more detailed explanation, you can read this blog post

Thank you, that did the trick!

By the way, the Rprofile.site file that came with the R I installed from CRAN (R-4.1.2) has the following commented out line as a suggestion for changing the library location:

set a site library

#.Library.site <- file.path(chartr("\", "/", R.home()), "site-library")
I tried commenting out the .Library.site line, and restarting R, but that didn't actually work!

But your code from your blog post (using .Libpaths) did!


Because of the way you have configured your Windows account, R.home() evaluates to the same OneDrive folder you have seen before so you haven't been making any actual change.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.