Tidyverse package Error

Hi All,

Tidyverse package was working fine yesterday. However, it throws me following error:

I just installed scales package as I read somewhere scales will solve the issue. However, I still have the same issue.

Any clue on this issue? Thanks for your help!


The error message is asking you to update rlang

1 Like

Thanks @andresrcs! I tried installing rlang. But I still get the same error :worried:

Tidyverse was working fine few days ago!

1 Like

Hi @ksingh19,
The latest error is telling you that the vctrs package you have installed is an older version than required.
Either do
or use the RStudio Packages > Update > Select All menu system to update all installed packages.

1 Like

Perfect! Thanks @DavoWW!

Quick question - Do I have to use this package every time now on. Because even for new script, it works only if I use this package or else it doesn't work.

Hi @ksingh19,
Sorry for the delay.
You just need to "load" the tidyverse set of packages for each R session (or RStudio project). Best practice is to have library(tidyverse) at the top of each script, that way the script is "self-contained" and reproducible.

Thank you @DavoWW! This helps!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.