tidyverse loading error: package or namespace load failed for 'tidyverse' in namespaceExport(ns, exports):

Getting what seems to be a very common error when trying to load tidyverse. Happened out of nowhere, not sure how or why it started happening but I've tried most solutions I was able to find and none have worked.

My package library is on a onedrive directory (company laptop) and I've read that can be an issue but again, why wasn't it an issue before? I created a new library directory in C:/ and still it wouldn't work.

Here is the error text:
Error: package or namespace load failed for ‘tidyverse’ in namespaceExport(ns, exports):
undefined exports: path_ext<-, as_fs_bytes, as_fs_path, as_fs_perms, dir_copy, dir_create, dir_delete, dir_exists, dir_info, dir_ls, dir_map, dir_tree, dir_walk, file_access, file_chmod, file_chown, file_copy, file_create, file_delete, file_exists, file_info, file_move, file_show, file_size, file_temp, file_temp_pop, file_temp_push, file_touch, fs_bytes, fs_path, fs_perms, group_ids, is_absolute_path, is_dir, is_file, is_file_empty, is_link, link_copy, link_create, link_delete, link_exists, link_path, path, path_abs, path_common, path_dir, path_expand, path_expand_r, path_ext, path_ext_remove, path_ext_set, path_file, path_filter, path_has_parent, path_home, path_home_r, path_join, path_norm, path_package, path_real, path_rel, path_sanitize, path_split, path_temp, path_tidy, path_wd, user_ids
In addition: Warning message:
S3 methods ‘!.fs_perms’, ‘&.fs_perms’, ‘+.fs_path’, ‘/.fs_path’, ‘==.fs_perms’, ‘[.fs_bytes’, ‘[.fs_path’, ‘[.fs_perms’, ‘[[.fs_bytes’, ‘[[.fs_path’, ‘[[.fs_perms’, ‘|.fs_perms’, ‘Ops.fs_bytes’, ‘as.character.fs_bytes’, ‘as.character.fs_perms’, ‘as_fs_bytes.default’, ‘as_fs_bytes.fs_bytes’, ‘as_fs_bytes.numeric’, ‘as_fs_path.NULL’, ‘as_fs_path.character’, ‘as_fs_perms.NULL’, ‘as_fs_perms.character’, ‘as_fs_perms.fs_perms’, ‘as_fs_perms.integer’, ‘as_fs_perms.numeric’, ‘as_fs_perms.octmode’, ‘format.fs_bytes’, ‘format.fs_perms’, ‘max.fs_bytes’, ‘min.fs_bytes’, ‘print.fs_bytes’, ‘print.fs_path’, ‘print.fs_perms’, ‘sum.fs_bytes’, ‘xtfrm.fs_path’ were declared in NAMESPACE but not found

If you live in Canada I will etransfer you a crisp Queen Elizabeth if you help me sort this out. Thank you in advance for any feedback.

Can you load tidyverse properly when using the R command line directly (bypassing RStudio)?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.