Tidyverse error in stringr - cannot use any packages w stringr

Sorry I am new to this community and meant to post this question under this heading tidyverse because stringr is part of the tidyverse. I will attempt to delete it from IDE. I am thinking right now I need to uninstall R and reload the entire program, because update.packages() has not worked for me or anything else I have tried...

Loading required package: acs
Loading required package: stringr
Error: package or namespace load failed for ‘stringr’ in inDL(x, as.logical(local), as.logical(now), …):
unable to load shared object ‘C:/Users/-/Documents/R/win- library/3.4/stringi/libs/x64/ stringi.dll’:
LoadLibrary failure: %1 is not a valid Win32 application.
I have a strange feeling that a function I ran to take a substring from the right of a string of characters, might have influenced this ‘stringr’ but I believe the function was called substringRight, not stringr. Still that makes me nervous that the names are similar.

I just wanted to mention that I have successfully been using a number of R packages on the same computer for several months now. This is the first time I have run into this error. I have 8GB i5 64 bit. This error is preventing me from using choroplethr and libridate and other packages.

I fixed this with

1 Like