This site can’t be reached refused to connect on mac

Hi everyone,

I am running RStudio 1.2.5001 and R 3.6.0 GUI 1.70 on macOS mojave version 10.14.6 and have come up with an issue that I would like some assistance in, if I launch my RStudio either by opening an .Rmd or .R or a project file it looks like this:

I tried reinstalling it, but it does not work. This started to show up after I installed sf on RStudio. Please let me know how to resolve this.

Hi, and welcome.

Here's how to tweak Mojave to listen on

1 Like

I did this and while this process seems to work the error still shows up when I open RStudio.

1 Like

Does it happen when you open RStudio without specifying a file, when you open an R or Rmd file from the Finder or both?

Sorry, but I'm not able to reproduce.

If you right click on the .Rmd file in the Finder, and then use Open With -> Other..., and navigate to your RStudio installation, does it then work as expected?

1 Like

Hi, I do have a similar problem when I tried to update RStudio today to v 1.2.5001. I'm also on Mojave (v 10.14.6) and use R version 3.6.0. I cannot even launch RStudio and get this same error when trying to open RStudio.
I had to install an older version of RStudio (1.1.463) which worked fine. However, I'd like to update to the most recent version.

Hi, and welcome.

I am running 1.2.5001 on the same version of Mojave, but under R version 3.6.1 (2019-07-05) -- "Action of the Toes" without this problem, so my first suggestion is to do the R upgrade.

Thank you for your suggestion, I've updated R to v 3.6.1 and tried to install RStudio v 1.2.5001 again but I the same error message came up when trying to launch RStudio.

1 Like

Weird. I can't figure out what I'm doing right. Usually, connection refused means nothing is listening, although sometimes it's a firewall issue. But probably the next thing to try is resetting ~/.rstudio-desktop. See

Thanks again for your suggestion. I have tried this yesterday and it did not resolve my issue. I've read some threads here in this community and it seems it happened previously with other RStudio or macOS upgrades. I'm working at the moment on RStudio version 1.1.463. I have only recently updated to Mojave and I had a RStudio version 1.2.xxxx working fine after the upgrade (unfortunately I can't recall the version and have no backup of the installer package, lesson learned), until I tried to update RStudio . I also tried the preview version 1.2.1578 without success.

1 Like

Bummer. Truly. I can see no reason why we share the same OS and software but get different experiences, unless, only theoretically, it's some low-level hardware stuff, but how likely is that. This illustrates one of the reasons that I'm leaving OS behind for *nix. Wish I had another suggestion.

I had a look again today and tried to install a RStudio version provided via our university system (v 1.2.1335 - which I could not find in the www) and it does work now. I'm suspecting now it has something to do with our antivirus software and will case this up with our IT department. Thanks for your responses and help.

1 Like

I started having the same issues w/ RStudio 1.2.5001 this past week. my issue first started on an iMac, and then hours later, a Macbook Pro.

@technocrat is your installation still working properly?

I've opened up a GitHub issue for this, in case anyone is interested in following/watching it for notifications:


Thanks for reporting back! It really helps others in your situation!

If you haven't already, you can try resetting RStudio's state:

RStudio Version 1.2.5001, R version 3.6.1 over Mojave 10.14.6 is working on my old Mac Air

I am having the same issue.

RStudio 1.2.5001
R version 3.6.1 (2019-07-05)
Platform: x86_64-apple-darwin15.6.0 (64-bit)
Running under: macOS Mojave 10.14.6

I had already reset RStudio's state as suggested. But it does not work.

I'm also having the same issue:
R version 3.6.1 (2019-07-05)
RStudio 1.2.5001 and 1.2.1578
Platform: x86_64-apple-darwin15.6.0 (64-bit)
OSX 10.14.6

I tried all the suggestions mentioned and had to finally reinstall my OS to figure it out.

1 Like

Hi all,

You could try reinstalling r with the following command:

brew reinstall r
brew unlink r && brew link r

This solved my issue.