Theme colors not rendering as in TmThemeEditor

Hi ! So perhaps I'm going crazy or perhaps I just cant find the answer to this but I cannot for the life of me get the color/themes of any of the TmThemes found on herokuapp to render properly in RStudio. I have tried converting it to rstheme, I have tried manually going in and changing values but nothing seems to work.

To add to the confusion, when creating a function <function_name> <- function(){} the <> when you inspect element is just "class="ace_identifier" but also so is literally everything else. When I open the rstheme file directly, there is no indicator for "ace_identifier", and when I add the tag and color directly, literally everything except for strings, numbers, else/ifs and punctuation becomes the color specified; there's no specification beyond "is this a punctuation, number, or an if/else".

Did something change in RStudio that caused loss of dimensions regarding the CSS? Why is -everything- just "ace_identifier" because it makes customization of themes impossible.

Has anyone found a solution to this I am missing? Thanks -

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.