The graph not showing up in the 'plots' pane in RStudio

My Rstudio got a problem like in the picture. The graph does not show in the Plot Pane.
Please help me to fix it.
Version: Rstudio 1.0.136
Thank you

Usually, simply closing that window that says R Graphics Device 2 (Active) is enough to have any further plots appear in the plot pane. Have you tried that?

1 Like

I have tried but it still appear when I run code again.

Usually closing that window, or resarting R or RStudio session works, as FJCC said. Since that's not the case with you, I'm going to give 3 suggestions, but please note that these are just guesses on my part.

  1. Update your RStudio. The current version is 1.2.1335, and your version 1.0.136 is very old.
  2. Run a few times, and then try to plot again.
  3. Run options(device = "RStudioGD"), and try to plot again.

Thank you so much, I upgraded to version 1.1.463 because my computer only supports 32bits, and the error has been fixed already.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.