Terminal turns to blank

My Rstudio terminal keeps in blank and does not react to any operation. I do see a "terminal 2" comes out, though if I create a new terminal by Tool > Terminal > New Terminal rather than clicking options in the terminal tab or shortcut). Originally I set it to show the git bash, and now the git function works from the "Git" tab but terminal shows nothing. I'll appreciate any help!

Terminal diagnosis:

Global Terminal Information
Loaded TerminalSessions: 0

Terminal List Count: 2
Handle: 'EF4D24C9' Caption: 'Terminal 1' Session Created: true
Handle: 'BCE06995' Caption: 'Terminal 2' Session Created: true

Session information:

> sessionInfo()
R version 3.5.0 (2018-04-23)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows >= 8 x64 (build 9200)

Matrix products: default

[1] LC_COLLATE=English_United States.1252  LC_CTYPE=English_United States.1252    LC_MONETARY=English_United States.1252
[4] LC_NUMERIC=C                           LC_TIME=English_United States.1252    

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
[1] compiler_3.5.0 tools_3.5.0

Hello, welcome to community! Sorry for the oddity.

I am a little confused as to what is done to get this to happen?

  • Are you following a particular pattern of interaction with your RStudio IDE before this occurs?
  • Can you provide any steps folks here might take to replicate this?

System Information:

  • RStudio Edition: (Desktop or Server)
  • RStudio Version:
  • OS Version: Windows >= 8
  • R Version: 3.5.0
  • RStudio application log files: rstd.io/support-ide-log-files

Hi, sorry for making these confusion. The issue just happened relatively after I did the Windows latest update (1803). The terminal worked perfect before that. I tried to reinstall the latest version of git and both stable and daily-building version of Rstudio. Nothing changes. Sorry I don't know how to provide replicated sample for this case, given this is not a problem of git or any command.

Here's the system information

RStudio Edition : Desktop
RStudio Version : 1.2.650
OS Version : x86_64-w64-mingw32/x64 (64-bit)
R Version : 3.5.0 (2018-04-23)
Applicaiton log: sorry, as a "new" user, I can't upload it here. Do you want me to attach it in the github issue?

I also posted an issue in Github, https://github.com/rstudio/rstudio/issues/2849, where you can see more information about the software environment I'm working on.

The problem is solved with a newer developing version of RStudio. More details are here https://github.com/rstudio/rstudio/issues/2849.

1 Like