Terminal in new R Studio seems buggy

I've been using new R Studio (v.1.1.383), on Mac, and have issues with typing into the terminal pane. Regular typing-in commands (e.g. 'ls' ) doesn't show up in terminal. I thought that this meant that somehow my keystrokes weren't being recognized. However, when I "mash" my keyboard, it seems like some keys get through. Also, whatever characters make it through can be simply deleted. So the delete key works fine, but the rest of the typing doesn't seem to be.

This is the case on three different mac computers that I work on. Searched this forum and haven't found any mention of the same issues, and was wondering if this was a known problem?

I am also using v.1.1.383 on a macOS. If I understand you correctly things like 'ls' in the console work for me. Is this what you are trying to do?


It works fine for me as well. What versions of R and mac OS are you using, @limacina? I'm using

  • RStudio 1.1.383
  • R version 3.4.2
  • mac OS Sierra 10.12.6

Do you have any special settings in Preferences >> Terminal ?

@mara: I am using:

  • R studio 1.1.383
  • R v.3.4.3
  • Mac OS Sierra 10.12.6

Having the same issue on at least 2 computers running this configuration. As far as the Prefernces >> terminal
, I had the same settings as you except "New terminals open with bash". I tried changing it to your specification of ~/usr/bin/zsh and have had no luck even after restarting R studio.

@danr - yes, that is what i am trying to do. I am having trouble typing commands into the terminal prompt. when I try to type something like ls, nothing appears after the $ prompt. However, I CAN copy-paste a ls in, which is particularly strange. When I copy-paste ls into the terminal, it outputs the appropriate list of files in the current directory.

I'm not sure that version's out yet…

Other than that, though, I have no clue. I'm not having the same issues…wiser minds will prevail, I"m sure. :+1:

Yikes - yes that's 3.4.1. Strange that it's happening on a few of my machines but not on anybody else's.

3.4.2 (Short Summer) is the current version, it was released at the end of Sept.

Could you attach your terminal diagnostics report? You can get it from Tools -> Terminal -> Terminal Diagnostics. Run that immediately after typing the characters that dropped.

Afterwards, try turning off local echo and websockets. Does that help?

Here's the attached terminal output. Turning off local terminal echo and web sockets in options has not fixed the issue.

Document1.pdf (29.0 KB)

After you turn off local terminal echo, and web sockets in options, running terminals won't be impacted.

So, could you try the following sequence:

  1. Turn off local-echo and websockets in options
  2. Create a new terminal instance (Tools -> Terminal -> New Terminal)
  3. Try typing commands in that new terminal

If the problem is still happening, then do Tools -> Terminal -> Diagnostics again, and send that.


1 Like

I have been suffering from the same problem on RStudio 1.1.442. I figured that RStudio terminal did not accept input when the keyboard was set to Japanese. Essentially, RStudio terminal pane does not recognize any keystroke when I am on "alphabets" mode of Japanese keyboard.

Adding U.S. keyboard on system preferences solved the problem. I suspect there has to be some oddities in RStudiio terminal.

1 Like

If I'm not mistaken, the screenshot @mara attached is probably from Linux, not Mac (since ~/usr doesn't generally exist on macOS out-of-the-box). Also, zsh doesn't come with macOS out-of-the-box either, so I'd probably stick with "New terminals open with bash" while you're troubleshooting this (otherwise you could end up with two problems masking each other).

EDIT: whoops, didn't realise how old this thread was :sweat_smile:


Thank you Yoshi - THIS WORKS! I didn't even think of this issue. For everyone else - on Mac, it's easy to switch between the Japanese keyboard and the Japanese-American keyboard, but not between the full Japanese and full American keyboard. This is 99% the same for everyday stuff, with the rare exceptions (backslash on the Japanese-American keyboard actually becomes the yen sign, or ¥). So because of this, I usually keep my keyboard on Japanese-American since I live in the US and only use Japanese to chat with my overseas parents.

Oh, the woes of being bilingual.... :slight_smile:

1 Like

Oh, it's my Mac. I run oh-my-zsh! Pretty sure my system doesn't look very "out of the box" these days! :smirk:




1 Like

There's a shortcut to switch keyboard input sources. I believe it's Opt-Space by default (or maybe I set that a long time ago), though I'm not sure if it's enabled.

To enable/set it, go to  > System Preferences > Keyboard > Shortcuts > Input Sources and make sure Select the previous input source is selected and set to something you'll remember. (You don't really need the other Select the next input source, because you can just hold Opt and keep pushing Space to select other options.) If you'd like to always be able to see which keyboard is active, click over to the Input Sources tab and select Show Input menu in menu bar, and a little flag/icon will appear on your menu ("A" for Romaji, and a US/UK flag for English). You can also click on it to switch keyboards if you forget your shortcut.