Terminal has stopped working, only displaying the directory of the project

I am using RStudio 2022.07.2. Yesterday, it stopped displaying the project on the Terminal. The history is still there and the Console functions as normal but all I get on the Terminal is the location of the project, which is repeated every time 'enter' is pushed.

The problem seems to have started when I attempted to open a project I had not used for several months and had been created in 1.2.5042. After that, I got the same problem with all projects, including the one I had been working on, without a problem, earlier in the day.

I have tried closing the Terminal and then exiting and then restarting RStudio; and removing and reinstalling RStudio but neither of these have worked.

Terminal Diagnostics gives the following:
Global Terminal Information

Loaded TerminalSessions: 1
Handle: 'E9B67BAA' Caption: 'Terminal 1'

Terminal List Count: 2
Handle: 'E9B67BAA' Caption: 'Terminal 1' Session Created: true
Handle: '95FEE02F' Caption: 'Terminal 2' Session Created: false

Global Terminal Information

Caption: 'Terminal 1'
Title: ''
Cols x Rows '63 x 38'
Shell: 'Command Prompt'
Handle: 'E9B67BAA'
Sequence: '1'
Restarted: 'true
Exit Code: 'null'
Full screen: 'client=false/server=false'
Zombie: 'false'
Track Env 'false'
Local-echo: 'false'
Working Dir: 'Default'
Interactive: 'Always'
WebSockets: 'true'

System Information------------------
Desktop: 'true'
Remote: 'false'
Platform: 'Windows'

Connection Information

2022/10/19 10:31:35: Connect WebSocket: 'ws://'
2022/10/19 10:31:35: WebSocket connected

Local-echo Match Failures

Any ideas on how to solve this would be appreciated. Thanks

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.