Tensorflow and Keras for R on Windows

Hello all together!

I've been trying to solve this problem for two weeks now, so I hope maybe one of you can help me with my issue.

I try to cretate a neural network using R, so first I tried to get tensorflow and keras running on my Windows machine.

I tried executing the following code:
sess <- tf$Session()

When I use the sessionInfo() command, I get the following:

R version 4.0.3 (2020-10-10)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 10 x64 (build 17763)

Matrix products: default

[1] LC_COLLATE=German_Germany.1252 LC_CTYPE=German_Germany.1252 LC_MONETARY=German_Germany.1252 LC_NUMERIC=C
[5] LC_TIME=German_Germany.1252

attached base packages:
[1] stats graphics grDevices utils datasets methods base

other attached packages:
[1] tensorflow_2.2.0.9000

loaded via a namespace (and not attached):
[1] Rcpp_1.0.5 compiler_4.0.3 prettyunits_1.1.1 base64enc_0.1-3 remotes_2.2.0 tools_4.0.3 testthat_3.0.0 digest_0.6.27
[9] pkgbuild_1.1.0 pkgload_1.1.0 jsonlite_1.7.1 memoise_1.1.0 lattice_0.20-41 rlang_0.4.8 Matrix_1.2-18 cli_2.1.0
[17] rstudioapi_0.13 withr_2.3.0 desc_1.2.0 fs_1.5.0 rappdirs_0.3.1 devtools_2.3.2 rprojroot_1.3-2 grid_4.0.3
[25] reticulate_1.18 glue_1.4.2 R6_2.5.0 processx_3.4.4 fansi_0.4.1 sessioninfo_1.1.1 callr_3.5.1 magrittr_2.0.1
[33] whisker_0.4 backports_1.2.0 ps_1.4.0 tfruns_1.4 ellipsis_0.3.1 usethis_1.6.3 assertthat_0.2.1 crayon_1.3.4

However, when I try to execute sess <- tf$Session(), I get an error message that "Python module tensorflow was not found."

Would really be looking forward to your help! Thank you a lot in advance!!! :slight_smile:

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.