Template docx document quarto

Hi everyone, I'm new to Quarto and I'm trying to set my template docx document.
I type in the terminal of RStudio : quarto pandoc -o custom-reference-doc.docx --print-default-data-file reference.docx but a I get the following error : quarto: The term 'quarto' is not recognized as a name of a cmdlet, function, script file, or executable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again. .
Any idea where this issue comes from?
I'm using RStudio 2023.06.1+524 "Mountain Hydrangea".
Thanks to everyone

Does it work when you use quarto.cmd ?
See https://forum.posit.co/t/bash-quarto-command-not-found/144187

Silly me! I thought I did not need tu install quarto because I was already able to render my quarto document from Rstudio. Then I separately installed quarto on my laptop and now it works fine

Happy if you are happy.

But your RStudio version of quarto should do the trick anyway ??

Do you mean that I should be able to do this from RStudio terminal without installing quarto?

You have a version installed with RStudio.
See https://quarto.org/docs/tools/rstudio.html

I saw that and I'm currently using RStudio to render quarto document. But before Installing quarto separately I was not able to use quarto commands from terminal. I don't know whether I'm getting this right or not.

Did you try the quarto.cmd command in the terminal (note the ".cmd" part) ?

If I use the Mac terminal it works fine but I get the following error from the Rstudo terminal : ERROR: Cannot determine the Quarto source path. This script must be run from the bin or common folder.
In bot case it does not work if I add the extension .cmd.
I'm using powershell as terminal

I think this means that your quarto input can not be found. So a different error than before.

In each type of terminal you should always be able to specify the full path for executable and inputs and outputs (?)

Firstly, thanks for your time.
Could you please elaborate more? I'm new to this topic and not so confident

Yes this should be working. Be sure to use the latest version of RStudio IDE though. Quarto should be available and available in PATH from Terminal window without you needing to install another one.

Though, if you want latest Quarto it is absolutely fine to install Quarto independently

Thanks for your time.
I'm still not able to use quarto commands using the R terminal.
Please find attached the results of quarto check from my MAC terminal and from R terminal.
Could you help me to get this solved?


What is the difference with your first screenshot and second ?

The first one seems to work and find quarto on your Mac at /Application/quarto/bin

The second one seems to look in /user/local/bin/quarto : do you know why the PATH is different ?

Also I see you work on cloud storage - is this happening only when calling from there ?

The first screen is from my Mac terminal, the second one from the terminal launched in R studio.
When I use this command from my Mac terminal everything works fine.
Yes, there seems to be some issues with my PATH but I've never worked from terminal and can't figure out what is going wrong.
Yet, If look for the path with both terminals, I get the same result. Screenshots attached (yellow one is from Mac terminal, the other one from R studio terminal).
Yes, the problems happens regardless the could storage

Thanks for your time
Screenshot 2023-08-31 at 14.59.11

I believe we recently fix something in our script related to this error. This was happening when there is a space in Quarto installation paths.

1.4.388 contains the fix if you want to try it so you can install latest 1.4 and it should solve this Quarto – Pre-release Builds

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.