TempDir preventing server from restarting

Appendix A2 in the RStudio Connect admin guide mentions the availability of a TempDir configuration option to bypass /temp if -noexec is enabled. We've tried setting this under the [Server] block in /etc/rstudio-connect/rstudio-connect.gcfg but haven't been able to make it work. RStudio Connect fails to restart with the message:

Couldn't read configuration file /etc/rstudio-connect/rstudio-connect.gcfg: warning:
can't store data at section "Server", variable "TempDir"

We set it up as:

TempDir = /other/directory

It looks like there are files being created in /other/directory, but the server refuses to restart.

We're running v1.5.8-12. Any insights on how we might be able to get this to work?

Hi @bogdanrau, I would recommend to email support@rstudio.com with this issue. RStudio Connect is a commercial product, so you should be able to take advantage of this service.

In the meanwhile, can we confirm that there's no duplicate [Server] tag?

Thanks Edgar. We've sent an email to support also. You are correct, no duplicate [Server] tag. We actually tried using DataDir which worked, but for some reason setting TempDir does not. What's interesting is that files DO get written to whatever TempDir we end up setting, but it'll eventually crash before the rsconnect fully restarts.

A late reply:

Server.TempDir is a configuration option added in RStudio Connect 1.5.10. It is an unknown property in 1.5.8 (thus the error).

The documentation for the 1.5.8 release is included in /opt/rstudio-connect/docs and also at http://docs.rstudio.com/connect/1.5.8/admin/

1 Like