Suppress parsing message when running query


I'm having trouble with suppressing the:

Parsing [========================================================================================] ETA:  0s

message (even though it's not actually a message) that comes from querying something using dplyr::collect() and connecting to a bigquery table.

I've tried all of the knitr options and using invisible, but they all are not working.

Is there a way I can silence this message earlier instead of trying to get .Rmd to ignore the message?

options("dplyr.show_progress" = FALSE)

Also did not work

messages option is usually the way to hide messages in the resulting document but it works if the underlying code in indeed using messages for that.

I believe you are using bigrquery package for that.

I understand from the code that it should be quiet in non interactive session. Does it show in the output document when you render() or in notebook mode in IDE under the chunk ?

I think the progressbar is done using progress package, and it should not show in R Markdown document. I tried this

title: "test"
  html_document: default

pb <- progress_bar$new(total = 100, clear = FALSE)
for (i in 1:100) {
  Sys.sleep(1 / 100)

This may come from somewhere else and without more information, I don't really know.

Hope it helps

Thank you so much for responding!

Yes, using bigrquery^

That's the strange thing. The "parsing" doesn't show up in the IDE under the chunk. It doesn't even show up in the R console when I run the function. It also doesn't show up when I click knit in the IDE. It only shows up when I use the render() function.

I'm working on trying to get a reprex together. I'll comment if I can get there.

When you use the render() function in the main session, you are considered in interactive mode. So it could come from this.

If you really don't want the progress bar at all, you could try setting


from the doc of progress :package: if this is indeed the one used ?progress::progress_bar

This should deactivate it completely

Some heroes wear capes. Others help folks on RSudioCommunity. Thank you so much!

1 Like

:laughing: thank you !

If your question's been answered (even by you!), would you mind choosing a solution? It helps other people see which questions still need help, or find solutions if they have similar problems. Here’s how to do it:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.