Studio not detecting R


I updated R to 4.2.2 and RStudio to 2022.12.0+353. My OS is MacOS Monterey (version 12.6.2) with Apple M1 chip.

I didn't have any errors during the installation of the packages and I am able to open R. However, when I try to open Rstudio, I get the following error: "R Not Installed. R does not appear to be installed. Please install R before using RStudio."

I tried to find a solution online, but was not able to solve it. Any help to solve this asap would be truly appreciated.


1 Like

I believe the latest RStudio version requires macOS >= 13, maybe that is the problem.

Thanks for your response. I tried to reinstall it after upgrading my OS to 13.2, but I am still getting the error :frowning:

Any other suggestions?

Thanks a lot for your help

I have been experiencing the identical problem. And have not been able to use RStudio successfully. @maryeveh - if you have arrived at a solution, I would appreciate hearing more. thanks.

Apple's change in version numbering starting with Big Sur has been confusing.

High Sierra = 10.13
Mojave = 10.14
Catalina = 10.15
Big Sur = 10.16 and 11.0
Monterey = 12.0
Ventura = 13.0

The current version of RStudio, 2022.12, requires macOS 11.0 or higher. Both 12.6.2 and 13.2 should have worked.

I am using Ventura (specifically 13.2.1). I have tried uninstalling all R and RStudio components and reinstalling from scratch after a full reboot of the desktop. Nothing is remedying the issue that @maryeveh originally reported. I agree that it appears it "should have worked". What next?


I have no idea, but if it was me I would post the components of R and RStudio that were deleted to make sure I really got them all. Sorry I cannot offer anything better.

You might find this useful. Resetting RStudio Desktop's State

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.