Student Issue with Loading Projects

Hi all,

I'm teaching a class, and one of my students is having issues loading any project. It seems like a common issue, but he has little data in any project, and cannot even load/create a new project.

Two questions:

  1. Could someone look into what's up with this? Associated account email is
  2. If there is a solution I can help him implement, please let me know. Seems like most of the solutions to this issue require intervention by an Rstudio employee. Only my students with Chromebooks use Rstudio cloud, but I'm interested in scaling it for future classes, and I'd like to be able to troubleshoot as many project opening issues as possible myself.

Hi, and welcome!

We've grown so used to SAAS just working that it's easy to forget that RStudio Cloud is still in \beta. I'm reliably informed by RStudio staff that the cloud team monitors here for issues, and recently there seems to have been a raft of them. From what I've seen, the solution usually entails killing the host process and re-spawning it. I've heard some reports of data thought to be lost reappearing, but I don't have any idea as to whether that is universal.

Also from what I've seen, usually the associated project id is needed for the rescue process, which makes sense because it discloses less than an email address.

I am fairly sure that there is nothing on the user end that can be done for this problem. A good practice if Chromebook flavored OS supports it would be to compose and save on RStudio Desktop for copying into cloud, so that a minimum of work is lost if this happens.

Whenever a coding issue comes up, please encourage your students to see the FAQ: What's a reproducible example (`reprex`) and how do I do one? Using a reprex, complete with representative data will attract quicker and more answers.

Also, of course, the homework policy.


Thank you for reaching out and I'm sorry to hear about the problem your student is having. I've looked into a couple of the student's recent project and I could not find issues on our side. Could you please provide the following information to help us further diagnose the issue:

  1. Is the student having the issue using a Chromebook? Are other students with Chromebooks having similar issues?
  2. Could you or your student provide more details on the actual project loading issue? Maybe provide some screenshots of the project loading issue?
  3. If possible, can the student use a different browser/computer to open their project?
  4. Have the student tried to empty their browser cache or use incognito mode to load the project?
1 Like

Thanks both for the insight. _Omar, thanks for looking into it and your time.

  1. This student is using an older Mac with an old OS. Has tried the different browsers and computers. Haven't tried browser cache or incognito mode- we'll look into that.
  2. Anytime he goes to load a project it gets stuck- see screenshot from trying to open a new project below.
1 Like

I can't tell whether the student's platform is directly responsible, but it may create many other headaches.

  1. RAM: 4GB is almost the minimum required for adequate performnce.
  2. macOS: ElCapitan is the minimum version to avoid handsprings in updating R
  3. R: Anything less than R3.5 is more likely to cause headaches

To be clearer: RStudio Cloud depends primarily on the browser. The "other" headaches relate to using RStudio Desktop or the macOS R GUI.

I would ask the student to log out of RStudio Cloud by using the menu in the upper right corner and selecting "Log Out". After that, the student should log back to RStuio Cloud and attempt to open their project.

It's extremely unlikely that the local operating system version and memory will have much of an impact in this case. RStudio Cloud runs in the browser, and the processing happens in the cloud. Any recent version of Chrome, Firefox, Safari, or Edge should be compatible.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.