Struggling with "rlang" during "tidyverse" package installation

Hi, I am new to RStudio. I am trying to install some packages. In many of them I got this error (see below). I have already tried to update, uninstall and install rlang, restart R studio, but nothing worked. Could you please recommend any ideas what to do?
Thank you



Installing package into ‘..R/x86_64-pc-linux-gnu-library/3.6’
(as ‘lib’ is unspecified)
also installing the dependencies ‘vctrs’, ‘ellipsis’, ‘broom’, ‘dbplyr’, ‘dplyr’, ‘dtplyr’, ‘ggplot2’, ‘googledrive’, ‘googlesheets4’, ‘haven’, ‘hms’, ‘modelr’, ‘pillar’, ‘tibble’, ‘tidyr’

  • installing source package ‘vctrs’ ...
    ** package ‘vctrs’ successfully unpacked and MD5 sums checked
    ** using staged installation
    ** libs
    ** R
    ** inst
    ** byte-compile and prepare package for lazy loading
    Error: .onLoad failed in loadNamespace() for 'rlang', details:
    call: NULL
    error: 'is_character' is not an exported object from 'namespace:rlang'
    Execution halted
    ERROR: lazy loading failed for package ‘vctrs’
  • removing ‘../R/x86_64-pc-linux-gnu-library/3.6/vctrs’
    Warning in install.packages :
    installation of package ‘vctrs’ had non-zero exit status

It seems there is a problem with the latest rlang version, a walk-around is to install a precompiled binary from the public RStudio Package Manager (if you are using a compatible Linux distribution)

If you need more specific help with this, please tell us exactly what Linux distribution and release you are using in your system.

1 Like

I hd same issue just two days ago. I removed R and again restall it and it worked. Before that I tried removing rland and re-installing it but it didn't work.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.