Struggling to deploy a Shiny App with private GitHub packages as dependencies


I'm new to using I wanted to deploy a small test app to see if it was suitable for scale.

I have built a shiny app which has 3 package dependencies for custom built packages sat in private GitHub repositories.

I have a PAT set up for GitHub, and building the package with: devtools::install_github("md0u80c9/SSNAPInterface") works - if I use the force parameter I can successfully force a rebuild.

In the settings panel, I have also checked the box marked 'Private Repository Access'

However, when I come to deploy the shiny app, I then see the error:
Error: Unhandled Exception: Child Task 665069826 failed: Error building image: Error fetching ssnapinterface (0.0.1) source. Error accessing GitHub repository md0u80c9/SSNAPInterface. Not Found

Can anyone think of anything else I need to check that would cause this to fail? Or anything else I need to do or should try to isolate what the problem is?

Is this a fork or the original repository?

it’s a private repo which was itself a fork from another private repo. Does that make a difference?

I'm not sure, just gathering some information to try to understand why it isn't working.

Are you able to point to the original private repo successfully? Or any other private repo?

Hi josh,

I haven’t tried that - I can try to do that in the next day or so (just away on a break at the moment).

I have done a rebuild into a public repo - which worked flawlessly but obviously has the problem of exposing the package as a public repo (which is not the end of the world but not desirable just yet - the package does analysis stuff that we would rather people used ‘validated’ toolsets for rather than rolled their own from forked versions of the source).

So I can do a rebuild into a private repo (or hopefully just flick a switch on the rebuilt repo to make it private).

This topic was automatically closed 54 days after the last reply. New replies are no longer allowed.