Some Keyboard Shortcuts Not Working

Selected Keyboard Shortcuts in RStudio of suddenly stopped working for me. For example, the insert pipe operator shotcust Ctrl+Shift+M will not work. I tried to re-assign the shortcut in the Keyboard Shortcuts editor dialog box, but when I attempt to this this, nothing appears in the shortcut column. However, if I try to assign something else, like Ctrl+Shift+N, this appears in the shortcut column and I can use it. I have tried resetting the shotcuts to their defaults and it displays Ctrl+Shift+M as the shorcut, but when I try to use this shortcut, nothing happens. I have searched the other forums online and here and none of the answers have helped. I do not have AMD Radeon overlay running as others have suggested. I am running version R Studio 2021.09.0 Build 351, with R Version [64-bit], Version R-4.1.1.

Any suggestions or ideas on how to resolve this?


So I have an additional update on this that might be helpful in helping find a solution to this: I've discovered that Ctrl+Shift+M Does work in code outside of a Project. When I attempt Ctrl+Shift+M in a project, it does not work. How can I get the Ctrl+Shift+M "insert pipe operator" to once again work in the code editor within an R Project?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.