[SOLVED] RStudio menu bar change after upgrading to Ubuntu 18.04, and zoom level cannot be saved

I recently upgraded my Ubuntu to 18.04, and work with RStudio 1.1.447. After the Ubuntu upgrade, the font and background of the menu bar of RStudio were changed completely. Before that, they were integrated nicely with the Ubuntu top menu font and color. Now everything is dull. I tried to delete the old desktop settings under ~/.rstudio-deskop, and reset everything again, however, nothing changed.

Before upgrade, it looks like: https://imgur.com/XQz31YI

After upgrade (not on 18.04, but same appearance after 18.04 upgrade), it is https://imgur.com/IYuBL3d

Also the zoom level cannot be saved under global options. Every time when I set the zoom level to 110%, it would be reset to 100% after relaunching RStudio.

Is there anything I can do or have to wait for the RStudio update for Ubuntu 18.04?

1 Like

Hi. I had the same problem on 17.10. Here's a full guide: http://pacha.hk/2017/10/20/quickly-install-r-on-ubuntu-17.10/

Try this printf '\nexport QT_STYLE_OVERRIDE=gtk\n' | sudo tee -a ~/.profile and then reboot.

I notice RStudio hangs after a few minutes on 18.04. I am trying to create a PPA building from source.

Thanks for the tips. It resolved the first issue. However, zoom level still cannot be fixed, and changed back to 100%.

Change the configuration file in ~/.config/RStudio/desktop.ini also didn't work, even though in the file the level was 1.1.

OK. I think the zoom problem has now been solve.

Just deleted ~/.config/RStudio/desktop.ini, and let RStudio created a new one after launch, and reset the zoom level. Now everything looks good.