SOLVED - Failed to build INLA for windows-latest (release) with check-standard.yaml

For reference, this is the solution to the issue with using INLA with GitHub Actions. Initial topic here:

The problem was trying to use install.packages for the stable inla version, which doesn’t work on the latest R version.

The solution is to use testing version of inla instead of the stable version.

The inla build is a bit tricky, and the failure of stable on windows is because install.packages tries to build the package from source, which isn’t supported in that way as it requires special building of the binaries.

Similarly, in the Description file, use Additional_repositories: pointing to the testing repo, in case there’s a system that supports that feature (and CRAN checks will like it as well). The inlabru package should generally be a good place to seek fixes for these kinds of issues, since it’s extensively tested and obeys CRAN requirements and has working GitHub Actions with inla testing (including helper code for only running inla dependent tests on systems with working inla installations; this has in the past solved issues where a CRAN server had a broken inla installation that couldn’t be updated…)

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.