Slow downloads in RStudio but not Rgui

Downloading files in RStudio is very slow for me. For example, if I run readabs::read_abs("6291.0.55.001", tables = 16) in RStudio it takes about 8 minutes to download the ~40MB file. However, if I run the same command in RGui, it takes only a couple of seconds. Downloading 'large' packages (like sf) are also painfully slow in RStudio.

I think the problem is confined to RStudio because my internet speed is good (>300 Mbps) and the problem doesn't occur in RGui. Other people in my organisation don't seem to have the same problem as me, but I cannot find any difference in our settings.

I'm running Version 1.3.1060 of RStudio with R version 4.0.2.


Same issue here. Ever since I upgraded to R 4.0, it's been an issue downloading data into RStudio, both from a MySQL AWS instance and CSV file from SFTP.

Haven't done a ton of exploring yet, but I imagine with the various upgrades (RStudio 1.3, R 4.0.2, Rtools, etc) that there is an issue somewhere.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.