Slow Connect Deployments with curl errors

Hi, I'm setting up RStudio Connect for my team and have been running into some challenges with publishing very basic content (e.g. 2 lines of ggplot code) which takes up to 40 minutes to publish to Connect.

The errors that I get are not consistent and sometimes occur and sometimes don't - so I'm having a hard time figuring out the actual problem to troubleshoot. In general though the errors are curl connection errors and Connect seems to keep trying to connect to the wrong repo even though I have specified the correct URL in options and on the server.

[Connect] 2020/05/07 03:05:17.235838283 curl: (7) Failed to connect to port 80: Connection timed out
[Connect] 2020/05/07 03:05:17.236204884 curl: HTTP 000
[Connect] 2020/05/07 03:05:17.237712640 Warning: unable to access index for repository (this is the incorrect URL)
[Connect] 2020/05/07 03:05:17.237730778 'curl' call had nonzero exit status
[Connect] 2020/05/07 03:05:17.273118611 curl: HTTP 200 (this is the correct URL)

I have setup RStudio Server Pro, Package Manager, and Connect. I have pointed to the package manager URL in the server config files including: repos.conf, rserver.conf, rsession.conf. For each user I have also configured their global options so that it points to the package manager repo and when I run options('repos') in the console I get the correct URL. I have also tried with port 80 both opened and closed.

I'm trying to figure out if this is a config error with Package Manager, a server error, or if perhaps my servers are just too small? (they are 2 cores with 8 gibs)

Hi @Rikagorn,

This looks like a problem with the repos configuration to me, but it sounds like you've hit most of the settings I'd suggest. The next step would probably be to ask you to share your config files, but I'm not sure you want to do that in public.

Since you're using RStudio Connect, you have access to our premium support (including on eval licenses). I'd encourage you to file a support ticket and work through this issue with a support engineer. Then maybe you can report back here if the solution turns out to be generalizable :slight_smile:

You can see more on submitting tickets here:

Thanks so much! It turned out that there was one more config file where I needed to delete the default CRAN url and input my RSPM address - /etc/rstudio-connect/rstudio-connect.gcfg

So in general for folks having difficulty connecting to their PM from Server when publishing to Connect, make sure to change the url in your config files on all 3 servers!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.