Slow and awkward processing Japanese characters on R Studio IDE

Thanks for a great app!

I have just switched from macOS to Windows 10 Pro, and found some problems typing in Japanese characters on R Studio for Windows, which I have never experienced on macOS.

  1. It takes longer time to see Japanese characters appear both on the editor and the console windows than other applications.
  2. R Studio IDE does not show Japanese characters while users type kana and the Input Method Editor translates those kana into kanji.
    This is a annoyance because one can not make sure proper kanji are translated from kana while typing. One can only do this only after kanji are decided.

I make movies to explain this.

This movie shows what is going when typing in Japanese characters on R Studio IDE.

This movie shows how it goes when typing in Japanese characters on a common Windows application. ( in this case, 'Hidemaru' editor)

I hope these videos and my explanation will make some sense.

I am in trouble with the same problem after upgrading to 1.2.x.
I am using MacOS Mojave.

I have the same problem on RStudio 1.2.1355 (macOS 10.14.5).
When I type Japanese characters on RStudio IDE, the characters are not displayed until I confirm Kana-Kanji conversion.
I tried the Preview Release 1.2.1541-1, but I experienced the same problem.
Reverting to the old version (RStudio 1.1.463) solved the problem, so it seems to be an issue specific to version 1.2.x.

Do you have any better luck with the v1.3 daily builds of RStudio?

I apologize for my late reply. I missed your reply until today.
I tried RStduio version 1.3.457, but I had a similar problem.
However, the behavior is slightly different.
In v1.2 (I tried v1.2.5001), only the first character is displayed and subsequent characters are not displayed.
On the other hand, in v1.3 (I tried v1.3.457), no character is displayed until I confirm Kana-Kanji conversion.