won't write any file type at any location

Yesterday I posted about an issue I am having with deploying a Shiny app to, the issue specifically being that the app wouldn't write to a .xlsx file or run an external r script, both of whcih are located in the same folder as the app. I was not able to resolve the issue but did some troubleshooting and was hoping that an updated version of the problem might be helpful in resolving it. Briefly, the app is supposed to read a .xlsx file, render one of the sheets in that file as a table, allow the user to modify the table, and then update the .xlsx file with the user-modified data, partly through some code located directly in the app and partly by running an external R script.

The app reads the .xlsx file and renders the table just fine. However, the code in the app does not send the data back to the .xlsx file, and the app does not run the external R script. Everything works fine when I run the app locally and all files are located in the same directory as the app.r file.

In my troubleshooting I've determined that the simply will not write any file of any type anywhere. Regardless of whether the app/files are on Dropbox (where ideally they would be located) or stored locally on my computer, the app simply does not appear to be capable of writing anything located outside of the app itself. This is also true regardless of the file type to be written. CSV, .xlsx, either written directly or using packages such as "rdrop2", it doesn't seem to make a difference and the app does not write files. The app not running the external code is an issue as I would like to keep things separated somewhat rather than having a single massive server file for the app, but if absolutely necessary I could include the external R script code in the app itself (although I'm hoping that if I can resolve the issue of not being able to write any external files that might also solve the issue of not being able to run the external R script.

Does anyone have any idea why I might be having this issue? This is my first Shiny app and I feel like I've tried everything. Do I need to give the app some kind of permission to write files, or is there something I need to do to enable it to write files that maybe I'm not aware of? Any help would be greatly appreciated, I've been stuck on this for some time at this point. Thank you.