stuck on "Please Wait" when visibility is to private. Works fine when set to public.

This is incredibility frustrating because I had an app working yesterday and now it gets stuck on "Please Wait" loading screen for no reason. I finally determined that changing visibility is the cause. I'm posting publicly in case others have this issue as I was unable to find a thread on the topic.

I've tried restarting, deleting, and deploying again and again. Updated R and all packages to latest version; tried all over again just to fail. Everything works when run locally and when visibility is set to public. When setting to private the app gets stuck on "Please Wait" upon opening.

I have existing apps set to private that work just fine for me and other employees. We have the Professional Plan (Monthly). I'm afraid to make any changes to other apps in case the same bug will make its way into them as well.

What am I missing? I even tried a very simple app such as below to convince myself it wasn't my code.

ui.R looks like this.

start_date <- lubridate::floor_date(Sys.Date(), 'month') - 1

dates <- tibble(dates = 0:12 %>% map(~ start_date %>% lubridate::add_with_rollback(months(-.x)))) %>% unnest(dates)


        label = "Select Inforce Date:",
        choices = dates$dates
    # Main panel for displaying outputs ----

server.R like this

server <- function(input, output) {

And I have a global.R.


SOLUTION! There was an issue with caching in my browser. Tried in incognito mode and another browser and I able to get past "Please Wait" to the login screen.

Clear all cookies if this happens to you.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.